C Program to Compare M * pow(2,n) and M<<N
Get number n and m, left shit the bits of n for m times:
Sample Input 1:
4 1
Sample Output 1:
8
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
#include<math.h>
int main()
{
int num,n,output1,output2;
printf("Enter a number and number of shifts:");
scanf("%d %d",&num,&n);
output1=num<<n;
output2=num*pow(2,n);
printf("%d %d",output1,output2);
return 0;
}
Program Explanation
left shift is equal to multiply a number with 2, left shift by n is equal to multiply with pow(2,n)Comments
Related Programs
- C Program to Addition of two numbers
- C Program to subtraction of two numbers
- C Program to multiply two numbers
- C Program to divide two numbers
- C Program to find modulus of two numbers
- C Program to convert Kilo Meters to Meters
- C Program to convert Meters to Kilo Meters
- C Program to find area of Square
- C Program to find area of Rectangle
- C Program to find area of Right angled triangle
- C Program to find area of triangle
- C Program to find area of Circle (Use Constant)
- C Program to find the distance between two points in 2D space
- C Program to calculate Salary of Employee
- C Program to convert kilobytes to bytes
- C Program to convert bytes to kilobytes
- C Program to find simple interest
- C Program to calculate Fahrenheit to Celsius
- C Program to calculate Celsius to Fahrenheit
- C Program to Swap two numbers using third variable
- C Program to Swap of two numbers without using third variable
- C Program to print the last digit of given number N
- C Program to toggle a bit in number
- C Program to initialize a variable to zero using XOR Operator
- C Program to Compare M divided by pow(2,n) and M>>N
coming Soon
coming Soon