C Program to print the last digit of given number N
Get an number n from user and display the last digit of n
Sample Input 1:
623
Sample Output 1:
3
Sample Input 2:
280
Sample Output 2:
0
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
int main()
{
int num,digit;
printf("Enter a number:");
scanf("%d",&num);
digit=num%10;
printf("Last digit: %d",digit);
return 0;
}
Program Explanation
Get a number num (using scanf statement) Seprate the last digit of number num by "digit = num%10".
(% by 10 always gives last digit of a number) print the digit (using printf statement)
Comments
Related Programs
- C Program to Addition of two numbers
- C Program to subtraction of two numbers
- C Program to multiply two numbers
- C Program to divide two numbers
- C Program to find modulus of two numbers
- C Program to convert Kilo Meters to Meters
- C Program to convert Meters to Kilo Meters
- C Program to find area of Square
- C Program to find area of Rectangle
- C Program to find area of Right angled triangle
- C Program to find area of triangle
- C Program to find area of Circle (Use Constant)
- C Program to find the distance between two points in 2D space
- C Program to calculate Salary of Employee
- C Program to convert kilobytes to bytes
- C Program to convert bytes to kilobytes
- C Program to find simple interest
- C Program to calculate Fahrenheit to Celsius
- C Program to calculate Celsius to Fahrenheit
- C Program to Swap two numbers using third variable
- C Program to Swap of two numbers without using third variable
- C Program to toggle a bit in number
- C Program to initialize a variable to zero using XOR Operator
- C Program to Compare M * pow(2,n) and M<<N
- C Program to Compare M divided by pow(2,n) and M>>N
coming Soon
coming Soon