Java Program to print the given fractional number in 2 digit decimal format
Get a fractional number from user and display the same in two digit precision
Sample Input 1:
56.3426
Sample Output 1:
56.34
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
import java.util.*;
class Demo
{
public static void main(String args[])
{
float num;
Scanner sc=new Scanner(System.in);
System.out.println("Enter The Fractional Number:");
num=sc.nextFloat();
System.out.printf("%.2f",num);
}
}
Program Explanation
The Scanner class, which is part of the java.util package, is used to get user input. To use the Scanner class, create an object of the class and call any of the methods listed in the documentation for the Scanner class. The nextFloat() method, which is used to read Fractional Numbers, are used in our example.
The Input is stored in the variable Input1 and printed in console using println() function which is the part of System.out package.
Format Specifier "%.2f" prints value as Floating Point Number with 2digit Precision(.00).
Comments
Related Programs
- Java Program to Print Welcome
- Java Program to Print the given Message
- Java Program to Print the given word
- Java Program to print the given integer number
- Java Program to print the given fractional number
- Java Program to print the ASCII value of a character
- Java Program to print two numbers with a space between them
- Java Program to print two numbers with a tab space between them
- Java Program to print two numbers in two lines
- Java Program to Print the Character of given ASCII Value
- println Statement Example in Java
- Literals in Java With Example
- Print and println difference with Example
- Command Line Argument Example in Java
- Implicit Type Conversion Example in Java
- Explicit Type Conversion Example in Java
- Escape Sequences and Format Specifiers Example in java
coming Soon
coming Soon