Java Program to Check whethet given String is Palindrome
Get a String and reverse the characters of the string. And check whether reverse order and original order is same.
Sample Input 1:
madam
Sample Output 1:
Palindrome
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
//To Check The Given String Is Palindrome...
import java.util.*;
class Program
{
public static void main(String args[])
{
String str,str1="";
int i;
Scanner sc=new Scanner(System.in);
System.out.println("Enter The String:");
str=sc.next();
int len=str.length();
for(i=len-1;i>=0;i--)
{
str1=str1+str.charAt(i);
}
System.out.println("The Reversed String Is:"+str1);
if(str.equals(str1))
{
System.out.println("This Is Palindrome...");
}
else
{
System.out.println("Not A Palindrome...");
}
}
}
Program Explanation
Comments
Related Programs
- Java Program to Print the English Alphabets In Lower Case
- Java Program to Count The Occurences Of Character In a String
- Java Program to Compare two Strings are Equal
- Java Program to Concatenate two Strings
- Java Program to Count the Occurences of Sub String
- Java Program to find the index of character in a String
- Java Program to find length of a string
- Java Program to convert lower case to upper case
- Java Program to Find the Location of Sub String in String
- Java Program to Reverse the Given String
- Java Program to Remove the Spaces in given String
- Java Program to Remove the Vowels in given String
- Java Program to insert space between every Characters
- Java Program to Convert Uppercase to Lowercase
- Java Program to Count the Vowels
coming Soon
coming Soon