Java Program to Count The Occurences Of Character In a String
Get a String and a character then count the occurrence of character in the string.
Sample Input 1:
Hello
l
Sample Output 1:
2
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
//Count The Occurences Of Given Character In A String ...
import java.util.*;
class Program
{
public static void main(String args[])
{
String word;
char ch;
Scanner sc=new Scanner(System.in);
System.out.println("Enter The Word:");
word=sc.nextLine();
int len1=word.length();
int i,count=0;
System.out.println("Enter The Character:");
ch=sc.next().charAt(0);
System.out.println("The Occurences Of Character Is:");
for(i=0;i<len1;i++)
{
if(ch==word.charAt(i))
{
count++;
}
}
System.out.println(" "+count);
}
}
Program Explanation
Comments
Related Programs
- Java Program to Print the English Alphabets In Lower Case
- Java Program to Compare two Strings are Equal
- Java Program to Concatenate two Strings
- Java Program to Count the Occurences of Sub String
- Java Program to find the index of character in a String
- Java Program to find length of a string
- Java Program to convert lower case to upper case
- Java Program to Find the Location of Sub String in String
- Java Program to Check whethet given String is Palindrome
- Java Program to Reverse the Given String
- Java Program to Remove the Spaces in given String
- Java Program to Remove the Vowels in given String
- Java Program to insert space between every Characters
- Java Program to Convert Uppercase to Lowercase
- Java Program to Count the Vowels
coming Soon
coming Soon