Program to check whether given Integer is Perfect Square or not
Sample Input 1:
49
Sample Output 1 :
49 is a Perfect Square (7*7=49)
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
# include <stdio.h>
# include <math.h>
int main()
{
int m, n ;
float p ;
printf("Enter a number : ") ;
scanf("%d", &n) ;
p = sqrt(n) ;
m = p ;
if (p == m)
printf("\n%d is a perfect square", n) ;
else
printf("\n%d is not a perfect square", n) ;
return 0;
}
Program Explanation
refer video tutorialComments
Related Programs
- Program to print the Factors of a Number N
- Program to check whether given Integer is Prime or Not
- Program to print the Prime numbers between two intervals
- Program to print the Prime Factors of N
- Program to check whether given Integer is perfect number or not
- Program to print the perfect numbers between two intervals
- Program to Print the Perfect squares between two intervals
- Program to check whether given Integer is whether integer is power of 2 or not
- Program to find GCD of given numbers
- Program to find LCM of given numbers
coming Soon
coming Soon