Program to print the Prime numbers between two intervals
Sample Input 1 :
10 40
Sample Output 1 :
11 13 17 19 23 29 31 37
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include <stdio.h>
int main()
{
int number, i, flag,start,stop;
printf("Enter two Numbers: ");
scanf("%d %d",&start,&stop);
printf("Prime between %d and %d are:\n",start,stop);
for(number=start;number<=stop;number++)
{
flag=0;
for(i=2; i<=number/2; ++i)
{
if(number%i==0)
{
flag=1;
break;
}
}
if(flag==0)
{
printf("%d ",number);
}
}
return 0;
}
Program Explanation
refer video tutorialComments
Related Programs
- Program to print the Factors of a Number N
- Program to check whether given Integer is Prime or Not
- Program to print the Prime Factors of N
- Program to check whether given Integer is perfect number or not
- Program to print the perfect numbers between two intervals
- Program to check whether given Integer is Perfect Square or not
- Program to Print the Perfect squares between two intervals
- Program to check whether given Integer is whether integer is power of 2 or not
- Program to find GCD of given numbers
- Program to find LCM of given numbers
coming Soon
coming Soon