Program to find GCD of given numbers
Sample Input 1 :
12 24
Sample Output 1 :
12
Flow Chart Design
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
int main()
{
int n,m,gcd,i;
printf("Enter two Numbers: ");
scanf("%d %d",&n,&m);
gcd= (n<m)?n:m;
while(1)
{
if(m%gcd==0&&n%gcd==0)
{
break;
}
gcd--;
}
printf("\n GCD is %d",gcd);
return 0;
}
Program Explanation
refer video tutorialComments
Related Programs
- Program to print the Factors of a Number N
- Program to check whether given Integer is Prime or Not
- Program to print the Prime numbers between two intervals
- Program to print the Prime Factors of N
- Program to check whether given Integer is perfect number or not
- Program to print the perfect numbers between two intervals
- Program to check whether given Integer is Perfect Square or not
- Program to Print the Perfect squares between two intervals
- Program to check whether given Integer is whether integer is power of 2 or not
- Program to find LCM of given numbers
coming Soon
coming Soon