Remove the spaces in given String using Pointers
Get a String and remove the spaces
Sample Input 1:
Hello World
Sample Output 1:
HelloWorld
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int main()
{
char *str;
int i,j;
str=calloc(sizeof(char),50);
fgets(str,50,stdin);
for(i=0,j=0;i<strlen(str)-1;i++)
{
if(*(str+i)!=' ')
{
*(str+j)=*(str+i);
j++;
}
}
str[j]='\0';
printf("%s",str);
return 0;
}
Program Explanation
Intialize two variables I and j as 0.
if it is space simply increment i.
If it is non-space store the character from index I to index j.
Comments
Related Programs
- C Program to get and print the array elements using pointers
- C Program to find the sum of array elements using pointers
- C Program to Search an Element in an array using Pointers
- C Program to find Smallest element in the array using pointers
- C Program to Reverse the Elements in array using pointers
- C Program to Sort the Elements in ascending order using pointers
- Find the Length of given String using Pointers
- Find the location of given Character in a String using Pointers
- Covert Lowercase characters to Uppercase Characters using Pointers
coming Soon
coming Soon