Last Digit of integer in Python
Python program to get an number n from user and display the last digit of n
Sample Input 1:
623
Sample Output 1:
3
Sample Input 2:
280
Sample Output 2:
0
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#write your code here
Program or Solution
num=int(input("enter the number:"))
ldigit=num%10
print("last digit: {}".format(ldigit))
Program Explanation
Get a number num (using input() method) Seprate the last digit of number num by "digit = num%10".
(% by 10 always gives last digit of a number) print the digit (using print() method)
Comments
Related Programs
- Python Addition
- Python Subtraction
- Python Multiplication
- Python Division
- Python Integer Division
- Python Modulus
- Python Exponentiation
- Kilometer to Meter in Python
- Meters to Kilo Meters in Python
- Area of Square in Python
- Area of Rectangle in Python
- Area of Right angled triangle in Python
- Area of triangle in Python
- Area of Circle in Python
- Circumference of Circle in Python
- Calculate Salary of Employee in Python
- Kilobytes to bytes in Python
- Bytes to kilobytes in Python
- Simple interest in Python
- Fahrenheit to Celsius in Python
- Celsius to Fahrenheit in Python
- Swap two numbers in Python
- Set a bit in Python | Reset a bit in Python
- Python Xor
- Python Left shift Operator
- Python Right Shift Operator
- Python Bitwise AND
- Python Bitwise OR
- Python Complement Operator
coming Soon
coming Soon