Set a bit in Python | Reset a bit in Python
Python program to get a number n and bit b, n is a number and b denotes any bit postion of n. set b postion of n as 1 if it is 0, reset b postion of n as 0 if it is 1.
Sample Input 1:
4 1
Sample Output 1:
5 Note: 4->0000 0100 After seting 1st Pos: 0000 0101
So output is 5.
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#write your code here
Program or Solution
num=int(input("Enter a Number:"))
bit=int(input("Enter any bit position:"))
n=1<<(bit-1);
num=num^n
print("The value after {} bit is: {}".format(bit,num));
Program Explanation
Get a number num and bit as input (using input() method) left shift 1 by bit times (n=1<Comments
Related Programs
- Python Addition
- Python Subtraction
- Python Multiplication
- Python Division
- Python Integer Division
- Python Modulus
- Python Exponentiation
- Kilometer to Meter in Python
- Meters to Kilo Meters in Python
- Area of Square in Python
- Area of Rectangle in Python
- Area of Right angled triangle in Python
- Area of triangle in Python
- Area of Circle in Python
- Circumference of Circle in Python
- Calculate Salary of Employee in Python
- Kilobytes to bytes in Python
- Bytes to kilobytes in Python
- Simple interest in Python
- Fahrenheit to Celsius in Python
- Celsius to Fahrenheit in Python
- Swap two numbers in Python
- Last Digit of integer in Python
- Python Xor
- Python Left shift Operator
- Python Right Shift Operator
- Python Bitwise AND
- Python Bitwise OR
- Python Complement Operator
coming Soon
coming Soon
Session Detail
Cookie CSRF: | |
Cookie Leetcode Session: |