C Program to calculate sum of N positive numbers(Accept the negative number And don?t include in sum)
Get input n and n integers, then compute the sum of positive integers
Sample Input 1:
5 6 7 2 -8 1
Sample Output 1:
16
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
int main()
{
int n,i,num,sum=0;
printf("Enter number of numbers to sum:");
scanf("%d",&n);
i=0;
printf("Enter %d numbers to sum:",n);
while(i<n)
{
scanf("%d",&num);
if(num>=0)
{
sum=sum+num;
}
i++;
}
printf("The Sum is: %d",sum);
return 0;
}
Program Explanation
user should give n positive integers, if user entered negative number continue statement skips only the sum statement.
So this program gets n numbers and sum the positive numbers.
Comments
Related Programs
- C Program to print N Natural numbers
- C Program to print Whole numbers till N
- C Program to print ODD numbers till N
- C Program to print Even numbers till N
- C Program to print N Natural numbers in reverse
- C Program to calculate sum of First N Natural numbers
- C Program to print N ODD numbers
- C Program to print N Even numbers
- C Program to calculate sum of Even numbers till N
- C Program to calculate sum of ODD numbers till N
- C Program to calculate sum of N given numbers
- C Program to print Hello World for N times
- C Program to print the first digit of a given number
- C Program to find whether the first digit of given number is odd or even
- C Program to multiply two numbers without using * operator
- C Program to find N power of M (Exponentiation) without using predefined function
- C Program to print Multiplication table of N
- C Program to print Multiplication table of N till M rows
- C Program to calculate sum of multiple positive numbers (Stop if user enters negative number)
- C Program to calculate sum of N positive numbers(Skip the negative number and get another instated of that)
- C Program to print all the English Alphabets in Upper case
- C Program to print all the English Alphabets in lower case
- C Program to print English Alphabets between two Alphabets
- C Program to print Lower case English Alphabets in reverse
- C Program to covert decimal to binary number
- C Program to convert binary todecimal number
coming Soon
coming Soon