C Program to find whether the first digit of given number is odd or even
Get input num and check whether the first digit of number num is odd or even
Sample Input 1:
34
Sample Output 1:
ODD
Sample Input 2:
67
Sample Output 2:
Even
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
int main()
{
int num;
printf("Enter a number:");
scanf("%d",&num);
while(num>=10)
{
num=num/10;
}
if(num%2==0)
{
printf("%d is even",num);
}
else
{
printf("%d is odd",num);
}
return 0;
}
Program Explanation
Instruction(s) inside the while block{} are executed repeatedly till expression (num>=10) is true.
Divide the number num by 10 untill it becomes lesser than 10.
once it is less than 10 check whether the num is odd or even.
statement num = num/10 divides the num by 10 repeatedly untill it num is less than 10.
Comments
Related Programs
- C Program to print N Natural numbers
- C Program to print Whole numbers till N
- C Program to print ODD numbers till N
- C Program to print Even numbers till N
- C Program to print N Natural numbers in reverse
- C Program to calculate sum of First N Natural numbers
- C Program to print N ODD numbers
- C Program to print N Even numbers
- C Program to calculate sum of Even numbers till N
- C Program to calculate sum of ODD numbers till N
- C Program to calculate sum of N given numbers
- C Program to print Hello World for N times
- C Program to print the first digit of a given number
- C Program to multiply two numbers without using * operator
- C Program to find N power of M (Exponentiation) without using predefined function
- C Program to print Multiplication table of N
- C Program to print Multiplication table of N till M rows
- C Program to calculate sum of multiple positive numbers (Stop if user enters negative number)
- C Program to calculate sum of N positive numbers(Skip the negative number and get another instated of that)
- C Program to calculate sum of N positive numbers(Accept the negative number And don?t include in sum)
- C Program to print all the English Alphabets in Upper case
- C Program to print all the English Alphabets in lower case
- C Program to print English Alphabets between two Alphabets
- C Program to print Lower case English Alphabets in reverse
- C Program to covert decimal to binary number
- C Program to convert binary todecimal number
coming Soon
coming Soon