C Program to print Multiplication table of N till M rows
Get input n and m, print the multiplication table of n till m
Sample Input 1:
4 7
Sample output 1:
1X4=4 2X4=8 3X4=12 4X4=16 5X4=20 6X4=24 7X4=28
Flow Chart Design
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
int main()
{
int n,m,i;
printf("Enter n and m value:");
scanf("%d %d",&n,&m);
for(i=1;i<=m;i++)
{
printf("%d X %d = %d\n",i,n,i*n);
}
return 0;
}
Program Explanation
Instruction(s) inside the for block{} are executed repeatedly till the second expression (i<=m)is true.
Here i is initialized to 1 and incremented by 1 for each iteration, instructions inside the for block are executed unless i becomes greater than m.
so value of i (1,2,3,...m)will be multiplied with n and printed in table format.
Comments
Related Programs
- C Program to print N Natural numbers
- C Program to print Whole numbers till N
- C Program to print ODD numbers till N
- C Program to print Even numbers till N
- C Program to print N Natural numbers in reverse
- C Program to calculate sum of First N Natural numbers
- C Program to print N ODD numbers
- C Program to print N Even numbers
- C Program to calculate sum of Even numbers till N
- C Program to calculate sum of ODD numbers till N
- C Program to calculate sum of N given numbers
- C Program to print Hello World for N times
- C Program to print the first digit of a given number
- C Program to find whether the first digit of given number is odd or even
- C Program to multiply two numbers without using * operator
- C Program to find N power of M (Exponentiation) without using predefined function
- C Program to print Multiplication table of N
- C Program to calculate sum of multiple positive numbers (Stop if user enters negative number)
- C Program to calculate sum of N positive numbers(Skip the negative number and get another instated of that)
- C Program to calculate sum of N positive numbers(Accept the negative number And don?t include in sum)
- C Program to print all the English Alphabets in Upper case
- C Program to print all the English Alphabets in lower case
- C Program to print English Alphabets between two Alphabets
- C Program to print Lower case English Alphabets in reverse
- C Program to covert decimal to binary number
- C Program to convert binary todecimal number
coming Soon
coming Soon