C Program to print N Even numbers
Get input n and print n even numbers.
Sample Input 1:
7
Sample Output 1:
2 4 6 8 10 12 14
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
int main()
{
int n,i,j;
printf("Enter a number:");
scanf("%d",&n);
printf("First %d even numbers are:\n",n);
for(j=1,i=0;j<=n;i=i+2,j++)
{
printf("%d ",i);
}
return 0;
}
Program Explanation
Instruction(s) inside the for block{} are executed repeatedly till the second expression (j<=n) is true.
Here i and j are initialized to 0 and 1 respecively.
i is incremented by 2 and j is incremented by 1.
for each iteration, instructions inside the for block are executed unless j becomes greater than n.
so value of i (0 2 4 6 8 10) (n even numbers) in each iteration will be printed using printf statement.
Comments
Related Programs
- C Program to print N Natural numbers
- C Program to print Whole numbers till N
- C Program to print ODD numbers till N
- C Program to print Even numbers till N
- C Program to print N Natural numbers in reverse
- C Program to calculate sum of First N Natural numbers
- C Program to print N ODD numbers
- C Program to calculate sum of Even numbers till N
- C Program to calculate sum of ODD numbers till N
- C Program to calculate sum of N given numbers
- C Program to print Hello World for N times
- C Program to print the first digit of a given number
- C Program to find whether the first digit of given number is odd or even
- C Program to multiply two numbers without using * operator
- C Program to find N power of M (Exponentiation) without using predefined function
- C Program to print Multiplication table of N
- C Program to print Multiplication table of N till M rows
- C Program to calculate sum of multiple positive numbers (Stop if user enters negative number)
- C Program to calculate sum of N positive numbers(Skip the negative number and get another instated of that)
- C Program to calculate sum of N positive numbers(Accept the negative number And don?t include in sum)
- C Program to print all the English Alphabets in Upper case
- C Program to print all the English Alphabets in lower case
- C Program to print English Alphabets between two Alphabets
- C Program to print Lower case English Alphabets in reverse
- C Program to covert decimal to binary number
- C Program to convert binary todecimal number
coming Soon
coming Soon