C Program to calculate sum of multiple positive numbers (Stop if user enters negative number)
Get positive integers from user till user enters a negative integer calculate sum of positive integers.
Sample Input 1:
5 6 7 2 1 8 -9
Sample Output 1:
29
Sample Input 2:
3 23 -76
Sample Output 2:
26
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
int main()
{
int num,sum=0;
printf("Enter Postive numbers to sum:");
while(1)
{
scanf("%d",&num);
if(num<0)
{
break;
}
sum=sum+num;
}
printf("%d",sum);
return 0;
}
Program Explanation
since 1 is always true, scanf statement gets input from user continously, if user enters a negative number it exit from while loop using break statement.Comments
Related Programs
- C Program to print N Natural numbers
- C Program to print Whole numbers till N
- C Program to print ODD numbers till N
- C Program to print Even numbers till N
- C Program to print N Natural numbers in reverse
- C Program to calculate sum of First N Natural numbers
- C Program to print N ODD numbers
- C Program to print N Even numbers
- C Program to calculate sum of Even numbers till N
- C Program to calculate sum of ODD numbers till N
- C Program to calculate sum of N given numbers
- C Program to print Hello World for N times
- C Program to print the first digit of a given number
- C Program to find whether the first digit of given number is odd or even
- C Program to multiply two numbers without using * operator
- C Program to find N power of M (Exponentiation) without using predefined function
- C Program to print Multiplication table of N
- C Program to print Multiplication table of N till M rows
- C Program to calculate sum of N positive numbers(Skip the negative number and get another instated of that)
- C Program to calculate sum of N positive numbers(Accept the negative number And don?t include in sum)
- C Program to print all the English Alphabets in Upper case
- C Program to print all the English Alphabets in lower case
- C Program to print English Alphabets between two Alphabets
- C Program to print Lower case English Alphabets in reverse
- C Program to covert decimal to binary number
- C Program to convert binary todecimal number
coming Soon
coming Soon