Count the number of vowels in given string
Get a String and count the number of vowels occurred in string.
Sample Input 1:
Hello
Sample Output 1:
2
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
#include<string.h>
int main()
{
char str[50];
char s[]={'a','e','i','o','u','A','E','I','O','U'};
int i,j,count=0;
fgets(str,50,stdin);
for(i=0;i<strlen(str)-1;i++)
{
for(j=0;j<strlen(s);j++)
{
if(str[i]==s[j])
{
count++;
break;
}
}
}
printf("%d vowels",count);
return 0;
}
Program Explanation
Get a String using fgets() function.
Str -> reads the string and stores it in str.
50 -> reads maximum of 50 characters stdin-> reads character from keyboard store vowels in array s.
for loop iterates and check each character whether it is in array s using inner for loop.
if it is in s, then increment count. Finally prints count.
Comments
Related Programs
- Print the characters of String with space
- Find the Length of given String
- Find the location of given Character in a String
- Count the occurences of given Character in a String
- Covert Lowercase characters to Uppercase Characters
- Covert Uppercase characters to Lowercase Characters
- Compare two Strings are equal
- Concate two given Strings
- Find the location of given sub string in a String
- Count the occurences of given substring in a String
- Reverse the given String
- Check the given string is Palindronme
- Remove the spaces in given String
- Remove the Vowels in given String
coming Soon
coming Soon