Covert Lowercase characters to Uppercase Characters
Get a String and convert the lower case characters to upper case Characters
Sample Input 1:
Hello
Sample Output 1:
HELLO
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
int main()
{
char str[50];
int i = 0;
fgets(str,50,stdin);
while(str[i]!='\0')
{
if(str[i]>=97 && str[i]<=122)
{
str[i]=str[i]-32;
}
i++;
}
printf("%s",str);
return 0;
}
Program Explanation
Get a String using fgets() function.
Str -> reads the string and stores it in str.
50 -> reads maximum of 50 characters stdin-> reads character from keyboard ASCII value of A to Z is 65 - 90 and a to z is 97 to 122.
for loop iterates and check each character whether it is s a to z, if it is in a to z then decrement it with 32 to get Upper Case.
Comments
Related Programs
- Print the characters of String with space
- Find the Length of given String
- Find the location of given Character in a String
- Count the occurences of given Character in a String
- Covert Uppercase characters to Lowercase Characters
- Count the number of vowels in given string
- Compare two Strings are equal
- Concate two given Strings
- Find the location of given sub string in a String
- Count the occurences of given substring in a String
- Reverse the given String
- Check the given string is Palindronme
- Remove the spaces in given String
- Remove the Vowels in given String
coming Soon
coming Soon