Find the location of given Character in a String
Get a String and a character then find where the character occurred first in the string.
Sample Input 1:
Hello l
Sample Output:
2
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
#include<string.h>
int main()
{
char str[50];
char s;
int i;
fgets(str,50,stdin);
scanf("%c",&s);
for(i=0;i<strlen(str)-1;i++)
{
if(str[i]==s)
{
printf("character found at %d",i);
return 0;
}
}
printf("character not found");
return 0;
}
Program Explanation
Get a String using fgets() function.
Str -> reads the string and stores it in str.
50 -> reads maximum of 50 characters stdin-> reads character from keyboard read character s using scanf() for loop iterates and check each character whether it is s.
if(str[i]==s) then prints I, else moves to next character.
Comments
Related Programs
- Print the characters of String with space
- Find the Length of given String
- Count the occurences of given Character in a String
- Covert Lowercase characters to Uppercase Characters
- Covert Uppercase characters to Lowercase Characters
- Count the number of vowels in given string
- Compare two Strings are equal
- Concate two given Strings
- Find the location of given sub string in a String
- Count the occurences of given substring in a String
- Reverse the given String
- Check the given string is Palindronme
- Remove the spaces in given String
- Remove the Vowels in given String
coming Soon
coming Soon