Remove the Vowels in given String
Get a String and remove the vowels
Sample Input 1:
Hello World
Sample Output 1:
Hll Wrld
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
#include<string.h>
int main()
{
char str[50];
char s[]={'a','e','i','o','u','A','E','I','O','U'};
int i,j,k,b;
fgets(str,50,stdin);
for(i=0,j=0;i<strlen(str)-1;i++)
{
b=0;
for(k=0;k<strlen(s);k++)
{
if(str[i]==s[k])
{
b=1;
break;
}
}
if(b==0)
{
str[j]=str[i];
j++;
}
}
str[j]='\0';
printf("%s",str);
return 0;
}
Program Explanation
Initialize two variables I and j as 0.
if it is vowel simply increment i.
If it is non-vowel store the character from index I to index j.
Comments
Related Programs
- Print the characters of String with space
- Find the Length of given String
- Find the location of given Character in a String
- Count the occurences of given Character in a String
- Covert Lowercase characters to Uppercase Characters
- Covert Uppercase characters to Lowercase Characters
- Count the number of vowels in given string
- Compare two Strings are equal
- Concate two given Strings
- Find the location of given sub string in a String
- Count the occurences of given substring in a String
- Reverse the given String
- Check the given string is Palindronme
- Remove the spaces in given String
coming Soon
coming Soon