Find the Length of given String
Get a String and count the characters in the string
Sample Input 1:
Hello
Sample Output 1:
5
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
#include<string.h>
int main()
{
char str[50],temp;
int i = 0;
fgets(str,50,stdin);
while(str[i]!='\0'&&str[i]!='\n')
{
i++;
}
printf("%d",i);
return 0;
}
Program Explanation
Get a String using fgets() function.
Str -> reads the string and stores it in str.
50 -> reads maximum of 50 characters stdin-> reads character from keyboard while loop iterates untill str has or
variable I increaments at each iteration, so finally i is the length of String.
Comments
Related Programs
- Print the characters of String with space
- Find the location of given Character in a String
- Count the occurences of given Character in a String
- Covert Lowercase characters to Uppercase Characters
- Covert Uppercase characters to Lowercase Characters
- Count the number of vowels in given string
- Compare two Strings are equal
- Concate two given Strings
- Find the location of given sub string in a String
- Count the occurences of given substring in a String
- Reverse the given String
- Check the given string is Palindronme
- Remove the spaces in given String
- Remove the Vowels in given String
coming Soon
coming Soon