C Program to Merging two arrays
Get two arrays and merge them into single array.
Sample Input 1:
3 5 4 2 4 9 7 6 3
Sample Output 1:
5 4 2 9 7 6 3
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
#include<stdlib.h>
int main()
{
int *a,*b,*c,n,m,i,j;
printf("Enter the sizes of two arrays:");
scanf("%d %d",&n,&m);
a=malloc(sizeof(int)*n);
b=malloc(sizeof(int)*m);
c=malloc(sizeof(int)*(n+m));
printf("Enter %d elements for first array:",n);
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
printf("Enter %d elements for Second array:",m);
for(i=0;i<m;i++)
{
scanf("%d",&b[i]);
}
i=0;
for(j=0;j<n;j++)
{
c[i]=a[j];
i++;
}
for(j=0;j<m;j++)
{
c[i]=b[j];
i++;
}
printf("After Merging:");
for(i=0;i<n+m;i++)
{
printf("%d ",c[i]);
}
return 0;
}
Program Explanation
Create a new array with size of size of a array + size of b array.
C[n+m] visit elements of a array and store it in c.
c[i]=a[j] i++ visit elements of b array and store it in c.
c[i]=b[j] i++
Comments
Related Programs
- C Program to get and print the array elements
- C Program to find the sum of array elements
- C Program to find the sum and average of array Elements
- C Program to Search an Element in an array
- C Program to find Largest element in the array
- C Program to find Smallest element in the array
- C Program to print all the numbers which are less than given key element from a given array.
- C Program to find Second Largest element in the array
- C Program to find Second smallest element in the array
- C Program to delete an element in an array
- C Program to Reverse the Elements in array
- C Program to reverse the first half of array elements
- C Program to reverse the second half of array elements
- C Program to Sort the Elements in ascending order
- C Program to Sort the Elements in descending order
- C Program to sort half of the Array elements in ascending order and next half in descending order
- C Program to replace every element with the greatest element on right side
- C Program to perform circular Array Rotation
- C Program to add two matrix
- C Program to multiply two matrix
- C Program to transpose the Matrix
coming Soon
coming Soon