C Program to delete an element in an array
Get an element and delete the element from array
Sample Input 1:
5 5 7 9 3 1 9
Sample Output 1:
5 7 3 1
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
#include<stdlib.h>
int main()
{
int *a,n,i,element;
printf("Enter size of array:");
scanf("%d",&n);
a=malloc(sizeof(int)*n);
printf("Enter %d Elements:",n);
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
printf("Enter a Element to delete:");
scanf("%d",&element);
for(i=0;i<n;i++)
{
if(a[i]==element)
{
while(i<n-1)
{
a[i]=a[i+1];
i++;
}
a[i]=0;
}
}
printf("After deleting %d:",element);
for(i=0;i<n;i++)
{
printf("%d ",a[i]);
}
return 0;
}
Program Explanation
visit every location in the array if current element in array a[i] is equal to the element which is to be deleted.
Then move all the elements located after i to its previous position using: a[i] = a[i+1]
Comments
Related Programs
- C Program to get and print the array elements
- C Program to find the sum of array elements
- C Program to find the sum and average of array Elements
- C Program to Search an Element in an array
- C Program to find Largest element in the array
- C Program to find Smallest element in the array
- C Program to print all the numbers which are less than given key element from a given array.
- C Program to find Second Largest element in the array
- C Program to find Second smallest element in the array
- C Program to Reverse the Elements in array
- C Program to reverse the first half of array elements
- C Program to reverse the second half of array elements
- C Program to Sort the Elements in ascending order
- C Program to Sort the Elements in descending order
- C Program to sort half of the Array elements in ascending order and next half in descending order
- C Program to Merging two arrays
- C Program to replace every element with the greatest element on right side
- C Program to perform circular Array Rotation
- C Program to add two matrix
- C Program to multiply two matrix
- C Program to transpose the Matrix
coming Soon
coming Soon