C Program to perform circular Array Rotation
Get array size n and n elements of array, rotate the elements of array in left side for m times.
Sample Input 1:
5 5 7 9 3 1 2
Sample Output 1:
9 3 1 5 7
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
#include<stdlib.h>
int main()
{
int *a,n,i,j,m,temp;
printf("Enter size of array:");
scanf("%d",&n);
a=malloc(sizeof(int)*n);
printf("Enter %d Elements:",n);
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
printf("Enter number of rotations:");
scanf("%d",&m);
for(i=1;i<=m;i++)
{
temp=a[0];
for(j=1;j<n;j++)
{
a[j-1]=a[j];
}
a[n-1]=temp;
}
printf("After %d rotations:\n",m);
for(i=0;i<n;i++)
{
printf("%d ",a[i]);
}
return 0;
}
Program Explanation
repeat the below steps for m times: store the a[0] in temp temp=a[0] move all elements located in 1 to n-1 to its previous location a[j-1]=a[j] store the temp in a[n-1] a[n-1]=tempComments
Related Programs
- C Program to get and print the array elements
- C Program to find the sum of array elements
- C Program to find the sum and average of array Elements
- C Program to Search an Element in an array
- C Program to find Largest element in the array
- C Program to find Smallest element in the array
- C Program to print all the numbers which are less than given key element from a given array.
- C Program to find Second Largest element in the array
- C Program to find Second smallest element in the array
- C Program to delete an element in an array
- C Program to Reverse the Elements in array
- C Program to reverse the first half of array elements
- C Program to reverse the second half of array elements
- C Program to Sort the Elements in ascending order
- C Program to Sort the Elements in descending order
- C Program to sort half of the Array elements in ascending order and next half in descending order
- C Program to Merging two arrays
- C Program to replace every element with the greatest element on right side
- C Program to add two matrix
- C Program to multiply two matrix
- C Program to transpose the Matrix
coming Soon
coming Soon