C Program to replace every element with the greatest element on right side
Get array size n and n elements of array, replace every elements with the greatest element located in right side.
Sample Input 1:
5 5 7 9 3 1
Sample Output 1:
9 9 3 3 1
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
#include<stdlib.h>
int main()
{
int *a,n,i,j,max;
printf("Enter size of array:");
scanf("%d",&n);
a=malloc(sizeof(int)*n);
printf("Enter %d Elements:",n);
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
for(i=0;i<n-1;i++)
{
max=a[i+1];
for(j=i+2;j<n;j++)
{
if(a[j]>max)
{
max=a[j];
}
}
a[i]=max;
}
printf("Output:\n");
for(i=0;i<n;i++)
{
printf("%d ",a[i]);
}
return 0;
}
Program Explanation
visit each location in array find the greatest element (max)next to the location using for(j=i+2;jComments
Related Programs
- C Program to get and print the array elements
- C Program to find the sum of array elements
- C Program to find the sum and average of array Elements
- C Program to Search an Element in an array
- C Program to find Largest element in the array
- C Program to find Smallest element in the array
- C Program to print all the numbers which are less than given key element from a given array.
- C Program to find Second Largest element in the array
- C Program to find Second smallest element in the array
- C Program to delete an element in an array
- C Program to Reverse the Elements in array
- C Program to reverse the first half of array elements
- C Program to reverse the second half of array elements
- C Program to Sort the Elements in ascending order
- C Program to Sort the Elements in descending order
- C Program to sort half of the Array elements in ascending order and next half in descending order
- C Program to Merging two arrays
- C Program to perform circular Array Rotation
- C Program to add two matrix
- C Program to multiply two matrix
- C Program to transpose the Matrix
coming Soon
coming Soon
Session Detail
Cookie CSRF: | |
Cookie Leetcode Session: |