C Program to Search an Element in an array
Get an element and find the location of element in array, print -1 if element is not found.
Sample Input 1:
5 5 7 9 3 1 9
Sample Output 1:
2
Sample Input 2:
5 5 7 9 3 1 4
Sample Output 2:
-1
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
Program or Solution
#include <stdio.h>
#include <stdlib.h>
int main(void)
{
int *a,n,i,pos=-1,element;
printf("Enter size of array:");
scanf("%d",&n);
a=malloc(sizeof(int)*n);
printf("Enter %d Elements:",n);
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
printf("Enter a element to find:");
scanf("%d",&element);
for(i=0;i<n;i++)
{
if(a[i]==element)
{
pos=i;
break;
}
}
printf("%d is in %d",element,pos);
return 0;
}
Program Explanation
i is initialized to 0 and incremented by 1 at each iteration of both the for loops.
First for loop reads n input numbers from user and stores them in array a[] from location 0 to n-1 using Second for loop the element is searched in each location from 0 to the location of element or location n-1.
if element is found in a location that location i is stored as pos and exit from the for loop using break statement.
if element is not found from 0 to n-1 location, pos remains -1.
Comments
Related Programs
- C Program to get and print the array elements
- C Program to find the sum of array elements
- C Program to find the sum and average of array Elements
- C Program to find Largest element in the array
- C Program to find Smallest element in the array
- C Program to print all the numbers which are less than given key element from a given array.
- C Program to find Second Largest element in the array
- C Program to find Second smallest element in the array
- C Program to delete an element in an array
- C Program to Reverse the Elements in array
- C Program to reverse the first half of array elements
- C Program to reverse the second half of array elements
- C Program to Sort the Elements in ascending order
- C Program to Sort the Elements in descending order
- C Program to sort half of the Array elements in ascending order and next half in descending order
- C Program to Merging two arrays
- C Program to replace every element with the greatest element on right side
- C Program to perform circular Array Rotation
- C Program to add two matrix
- C Program to multiply two matrix
- C Program to transpose the Matrix