Java Program to Arithmetic Calculator using switch case Statements
Get a binary arithmetic expression and solve the expression.
Sample Input 1:
12 + 9
Sample Output 1:
21
Sample Input 2:
4 * 5
Sample Output 2:
20
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
import java.util.*;
class Calculator
{
public static void main(String args[])
{
int num1,num2;
double output=0;
char operator;
Scanner sc=new Scanner(System.in);
System.out.println("Enter a Binary Expression:");
num1=sc.nextInt();
operator=sc.next().charAt(0);
num2=sc.nextInt();
switch(operator)
{
case '+':
output=num1+num2;
break;
case '-':
output=num1-num2;
break;
case '*':
output=num1*num2;
break;
case '/':
output=num1/num2;
break;
case '%':
output=num1%num2;
break;
default :
System.out.println("invalid operation");
break;
}
System.out.println("The Output Is:"+output);
}
}
Program Explanation
Based on the choice, instructions in any one of the case will be executed.
Break statement very important in switch.
Comments
Related Programs
- Java Program to calculate discount of 5% for purchase above 5000
- Java Program to find greatest among two numbers
- Java Program to find smallest among two numbers
- Java Program to find whether the given number is odd or even number
- Java Program to find whether the difference between two numbers is even or odd
- Java Program to find whether the given number is 3 digit number or not
- Java Program to find greatest among three numbers
- Java Program to find smallest among three numbers
- Java Program to find whether the given number is divisible by 3
- Java Program to find whether the last digit of given number is divisible by 3
- Java Program to grade calculation system
- Java Program to find the whether the last digit of given two numbers are equal or not
- Java Program to Calculate Different Discounts to Bill Amount
- Java Program to find whether Leap Year or Not Leap Year
coming Soon
coming Soon