Java Program to find greatest among three numbers
Get three numbers num1, num2 and num3 and find the greatest one among num1,num2 and num3.
Sample Input 1:
5 6 2
Sample Output 1:
6
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
import java.util.*;
class Checker
{
public static void main(String args[])
{
int num1,num2,num3;
Scanner sc=new Scanner(System.in);
System.out.println("Enter three numbers:");
num1=sc.nextInt();
num2=sc.nextInt();
num3=sc.nextInt();
if((num1 > num2) && (num1 > num3))
{
System.out.println("The Greatest Is "+num1);
}
else if(num2 > num3)
{
System.out.println("The Greatest Is "+num2);
}
else
{
System.out.println("The Greatest Is "+num3);
}
}
}
Program Explanation
1. Get three inputs num1,num2 and num3 from user using scanner class
2. check whether num1 is greater than num2 and num1 is greater than num3 using if statement.
if num1 is greater
2a. print num1 using system.out.println,
else
2b. check whether num2 is greater than num1 using elseif statement.
If num2 is greater
2b1. print num2 using printf statement,
else
2b2. print num3 using system.out.println.
Comments
Related Programs
- Java Program to calculate discount of 5% for purchase above 5000
- Java Program to find greatest among two numbers
- Java Program to find smallest among two numbers
- Java Program to find whether the given number is odd or even number
- Java Program to find whether the difference between two numbers is even or odd
- Java Program to find whether the given number is 3 digit number or not
- Java Program to find smallest among three numbers
- Java Program to find whether the given number is divisible by 3
- Java Program to find whether the last digit of given number is divisible by 3
- Java Program to Arithmetic Calculator using switch case Statements
- Java Program to grade calculation system
- Java Program to find the whether the last digit of given two numbers are equal or not
- Java Program to Calculate Different Discounts to Bill Amount
- Java Program to find whether Leap Year or Not Leap Year
coming Soon
coming Soon