Java Program to find whether Leap Year or Not Leap Year
Get a year and check whether year is leap year or not.
sample Input 1:
2016
Sample Output 1:
Leap year
Sample Input 2:
2017
Sample Output 2:
Not Leap Year
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
//To Find Whether Given Year Is Leap Year Or Not...
import java.util.*;
class Program
{
public static void main(String args[])
{
int year;
Scanner sc=new Scanner(System.in);
System.out.println("Enter The Year:");
year=sc.nextInt();
if(year%4==0)
{
System.out.println("This is Leap Year...");
}
else
{
System.out.println("Not A Leap Year...");
}
}
}
Program Explanation
Comments
Related Programs
- Java Program to calculate discount of 5% for purchase above 5000
- Java Program to find greatest among two numbers
- Java Program to find smallest among two numbers
- Java Program to find whether the given number is odd or even number
- Java Program to find whether the difference between two numbers is even or odd
- Java Program to find whether the given number is 3 digit number or not
- Java Program to find greatest among three numbers
- Java Program to find smallest among three numbers
- Java Program to find whether the given number is divisible by 3
- Java Program to find whether the last digit of given number is divisible by 3
- Java Program to Arithmetic Calculator using switch case Statements
- Java Program to grade calculation system
- Java Program to find the whether the last digit of given two numbers are equal or not
- Java Program to Calculate Different Discounts to Bill Amount
coming Soon
coming Soon