Java Program to find whether the given number is divisible by 3
Get a number num and check whether num is divisible by 3.
Sample Input 1:
27
Sample Output 1:
Divisible by 3
Sample Input 2:
43
Sample Output 2:
Not divisible by 3
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
import java.util.*;
class Checker
{
public static void main(String args[])
{
int num;
Scanner sc=new Scanner(System.in);
System.out.println("Enter The Number:");
num=sc.nextInt();
if(num%3==0)
System.out.println("The Number Is Divisible By 3.");
else
{
System.out.println("The Number Is Not Divisible By 3.");
}
}
}
Program Explanation
1. Get input num from user using scanner class.
2. check whether the remainder of num divided by 3 is equal to 0 using if statement.
if it is 0, then
2a. print num is divisible by 3 using system.out.println.
else
2b. print num is not divisible by 3 using system.out.println.
Comments
Related Programs
- Java Program to calculate discount of 5% for purchase above 5000
- Java Program to find greatest among two numbers
- Java Program to find smallest among two numbers
- Java Program to find whether the given number is odd or even number
- Java Program to find whether the difference between two numbers is even or odd
- Java Program to find whether the given number is 3 digit number or not
- Java Program to find greatest among three numbers
- Java Program to find smallest among three numbers
- Java Program to find whether the last digit of given number is divisible by 3
- Java Program to Arithmetic Calculator using switch case Statements
- Java Program to grade calculation system
- Java Program to find the whether the last digit of given two numbers are equal or not
- Java Program to Calculate Different Discounts to Bill Amount
- Java Program to find whether Leap Year or Not Leap Year
coming Soon
coming Soon