Java Program to Calculate Different Discounts to Bill Amount
Get price and quantity of a product, calculate bill amount, calculate 10% discount for the bill amount 5000 and above, 5% discount for the bill amount 1000 and above.
Sample Input 1:
10 400
Sample Output 1:
3800
Sample Input 2:
10 500
Sample Output 2:
4500
Flow Chart Design
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
//To Calculate Different Discount For Different Bill Amount...
import java.util.*;
class Program
{
public static void main(String args[])
{
int qua,price;
double amount=0,discount=0;
Scanner sc=new Scanner(System.in);
System.out.println("Enter The Price:");
price=sc.nextInt();
System.out.println("Enter The Quantity:");
qua=sc.nextInt();
amount=price*qua;
if(amount>=5000)
{
discount=amount*0.10;
}
else if(amount>1000)
{
discount=amount*0.05;
}
else
{
discount=0;
}
amount=amount-discount;
System.out.println("The Amount Is:"+amount);
}
}
Program Explanation
Comments
Related Programs
- Java Program to calculate discount of 5% for purchase above 5000
- Java Program to find greatest among two numbers
- Java Program to find smallest among two numbers
- Java Program to find whether the given number is odd or even number
- Java Program to find whether the difference between two numbers is even or odd
- Java Program to find whether the given number is 3 digit number or not
- Java Program to find greatest among three numbers
- Java Program to find smallest among three numbers
- Java Program to find whether the given number is divisible by 3
- Java Program to find whether the last digit of given number is divisible by 3
- Java Program to Arithmetic Calculator using switch case Statements
- Java Program to grade calculation system
- Java Program to find the whether the last digit of given two numbers are equal or not
- Java Program to find whether Leap Year or Not Leap Year
coming Soon
coming Soon