Java Program to find smallest among two numbers
Get two numbers num1 and num2 and find the smallest one among num1 and num2.
Sample Input 1:
5 6
Sample Output 1:
5
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
import java.util.*;
class SmallerTw
{
public static void main(String args[])
{
int num1,num2;
Scanner sc=new Scanner(System.in);
System.out.println("Enter The Two Numbers:");
num1=sc.nextInt();
num2=sc.nextInt();
if(num1<num2)
{
System.out.println(num1);
}
else if(num2<num1)
{
System.out.println(num2);
}
}
}
Program Explanation
1. Get two inputs num1 and num2 from user using scanner class.
2. check whether num1 is smaller than num2 using if statement.
if num1 is smaller
2a. print num1 using printf statment,
else
2b. check whether num2 is smaller than num1 using elseif statement.
If num2 is smaller
2b1. print num2 using system.out.println,
else
2b2. print "num1 and num2 are equal" using system.out.println.
Comments
Related Programs
- Java Program to calculate discount of 5% for purchase above 5000
- Java Program to find greatest among two numbers
- Java Program to find whether the given number is odd or even number
- Java Program to find whether the difference between two numbers is even or odd
- Java Program to find whether the given number is 3 digit number or not
- Java Program to find greatest among three numbers
- Java Program to find smallest among three numbers
- Java Program to find whether the given number is divisible by 3
- Java Program to find whether the last digit of given number is divisible by 3
- Java Program to Arithmetic Calculator using switch case Statements
- Java Program to grade calculation system
- Java Program to find the whether the last digit of given two numbers are equal or not
- Java Program to Calculate Different Discounts to Bill Amount
- Java Program to find whether Leap Year or Not Leap Year
coming Soon
coming Soon