Java Program to find the whether the last digit of given two numbers are equal or not
Get two numbers num1 and num2 and check whether last digit of num1 and num2 are equal or not?.
Sample Input 1:
65 45
Sample Output 1:
Last Digits are Equal.
Sample Input 2:
35 38
Sample Output 2:
Last Digits are Not Equal
Flow Chart Design
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
import java.util.*;
class LastDEqual
{
public static void main(String args[])
{
int num1,num2;
Scanner sc=new Scanner(System.in);
System.out.println("Enter two numbers:");
num1=sc.nextInt();
num2=sc.nextInt();
if(num1%10==num2%10)
{
System.out.println("Last Digits Are Equal.");
}
else
{
System.out.println("Last Digits Are Not Equal.");
}
}
}
Program Explanation
1. Get two inputs num1 and num2
2. extract the last digits of num1 and num2 using %10,
3. then compare last digits.
Comments
Related Programs
- Java Program to calculate discount of 5% for purchase above 5000
- Java Program to find greatest among two numbers
- Java Program to find smallest among two numbers
- Java Program to find whether the given number is odd or even number
- Java Program to find whether the difference between two numbers is even or odd
- Java Program to find whether the given number is 3 digit number or not
- Java Program to find greatest among three numbers
- Java Program to find smallest among three numbers
- Java Program to find whether the given number is divisible by 3
- Java Program to find whether the last digit of given number is divisible by 3
- Java Program to Arithmetic Calculator using switch case Statements
- Java Program to grade calculation system
- Java Program to Calculate Different Discounts to Bill Amount
- Java Program to find whether Leap Year or Not Leap Year
coming Soon
coming Soon