Java Program to print N Natural numbers
Get input n and print natural numbers till n.
Sample Input 1:
7
Sample Output 1:
The First Natural numbers are: 1 2 3 4 5 6 7
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
import java.util.*;
class Natural
{
public static void main(String args[])
{
int limit,i;
System.out.println("Enter The Limit:");
Scanner sc=new Scanner(System.in);
limit=sc.nextInt();
System.out.println(" The First Natural Numbers are:\n");
for(i=1;i<=limit;i++)
{
System.out.print(" "+i);
}
}
}
Program Explanation
1. Get input limit (upto which number natural numbers to be printed)
2. Instruction(s) inside the for block{} are executed repeatedly till i less than or equal to limit. (i<=limit)
for(i=1;i<=limit;i++)
3. Here i is initialized to 1 and incremented by 1 for each iteration, instructions inside the for block are executed in every iteration. Iteration stops when i becomes greater than limit.
so value of i will be printed like 1 2 3 ....limit
Comments
Related Programs
- Java Program to print N Whole numbers
- Java Program to print N Natural numbers in reverse
- Java Program to calculate sum of First N Natural numbers
- Java Program to calculate sum of N given numbers
- Java Program to print sum of N ODD numbers
- Java Program to print Sum of N Even numbers
- Java Program to print ODD numbers till N
- Java Program to print Even numbers till N
- Java Program to calculate sum of Even numbers till N
- Java Program to calculate sum of ODD numbers till N
- Java Program to print Hello World for N times
- Java Program to print the first digit of a given number
- Java Program to find whether the first digit of given number is odd or even
- Java Program to multiply two numbers without using * operator
- Java Program to print Multiplication table of N
- Java Program to print English Alphabets between two Alphabets
- Java Program to Print the English Alphabets In Lower Case
- Java Program to Print the English Alphabets In Lower Case
- Java Program to find Exponentiation
- Java Program to print alphabets in reverse
- Java Program to N th Multiplication table till M
- Java Program to sum N Postive numbers, Skip Negative Numbers.
- Java Program to find The Sum Of Multiple Positive Number,Stops If user Enters Negative Numbers
coming Soon
coming Soon