Java Program to calculate sum of N given numbers
Get input n and n inputs and calculate the sum of n inputs.
Example:
Sample Input 1:
4
6 5 3 2
Sample Output 1:
16
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
Program or Solution
import java.util.*;
class SumOfNInputs
{
public static void main(String args[])
{
int i,n,num,sum=0;
System.out.println("Enter Number Of Numbers You Want To Sum");
Scanner sc=new Scanner(System.in);
n=sc.nextInt();
System.out.println("Enter The Numbers To Sum");
for(i=1;i<=n;i++)
{
num=sc.nextInt();
sum=sum+num;
}
System.out.println("The Sum Is: "+sum);
}
}
Program Explanation
1. Get input n (How many values to be added)
2. Instruction(s) inside the for block{} are executed repeatedly till the second expression (j<=n) is true.
for(i=1;i<=n;i++)
3. Here i is initialized to 1 and incremented by 1 for each iteration, instructions inside the for block are
executed in every iteration. iteration stops when i becomes greater than n.
num=sc.nextInt();
sum=sum+num;
so value of num given by user will be added to sum at each iteration.
sum = sum + num
sum = 0 + 5 (if 5 given)
sum = 5 + 2 (if 2 given)
sum = 7 + 9 (if 9 given)
...........
...........
after adding all n numbers given by user to sum, sum will be printed using system.out.println.
Comments
Related Programs
- Java Program to print N Natural numbers
- Java Program to print N Whole numbers
- Java Program to print N Natural numbers in reverse
- Java Program to calculate sum of First N Natural numbers
- Java Program to print sum of N ODD numbers
- Java Program to print Sum of N Even numbers
- Java Program to print ODD numbers till N
- Java Program to print Even numbers till N
- Java Program to calculate sum of Even numbers till N
- Java Program to calculate sum of ODD numbers till N
- Java Program to print Hello World for N times
- Java Program to print the first digit of a given number
- Java Program to find whether the first digit of given number is odd or even
- Java Program to multiply two numbers without using * operator
- Java Program to print Multiplication table of N
- Java Program to print English Alphabets between two Alphabets
- Java Program to Print the English Alphabets In Lower Case
- Java Program to Print the English Alphabets In Lower Case
- Java Program to find Exponentiation
- Java Program to print alphabets in reverse
- Java Program to N th Multiplication table till M
- Java Program to sum N Postive numbers, Skip Negative Numbers.
- Java Program to find The Sum Of Multiple Positive Number,Stops If user Enters Negative Numbers