Java Program to print Sum of N Even numbers
Get input n and print n even numbers.
Sample Input 1:
7
Sample Output 1:
The sum of N Even numbers:56
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
Program or Solution
import java.util.*;
class SumOfNEven
{
public static void main(String args[])
{
int i,j,N,sum=0;
System.out.println("Enter The Value Of N");
Scanner sc=new Scanner(System.in);
N=sc.nextInt();
for(j=1,i=2;j<=N;i=i+2,j++)
{
sum=sum+i;
}
System.out.println("The Sum Of N Even Numbers: "+sum);
}
}
Program Explanation
1. Get input N (How many even numbers to be summed)
2. Instruction(s) inside the for block{} are executed repeatedly till the second expression (j<=N) is true.
for(j=1,i=2;j<=N;i=i+2,j++)
3. Here i is initialized to 2 and j is initialized to 1 and i is incremented by 2 and j is incremented by 1 for each iteration.
instructions inside the for block are executed in every iteration and iteration stops when j becomes greater than N. so value of i (2,4,6... ) will be added to sum.
so even numbers (i) are added to the sum for j --> 1 to N times
sum = sum + j
sum = 0 + 2
sum = 2 + 4
sum = 6 + 6
sum = 12 + 8
..................
..................
after adding all N even numbers to sum, sum will be printed using system.out.println().
Comments
Related Programs
- Java Program to print N Natural numbers
- Java Program to print N Whole numbers
- Java Program to print N Natural numbers in reverse
- Java Program to calculate sum of First N Natural numbers
- Java Program to calculate sum of N given numbers
- Java Program to print sum of N ODD numbers
- Java Program to print ODD numbers till N
- Java Program to print Even numbers till N
- Java Program to calculate sum of Even numbers till N
- Java Program to calculate sum of ODD numbers till N
- Java Program to print Hello World for N times
- Java Program to print the first digit of a given number
- Java Program to find whether the first digit of given number is odd or even
- Java Program to multiply two numbers without using * operator
- Java Program to print Multiplication table of N
- Java Program to print English Alphabets between two Alphabets
- Java Program to Print the English Alphabets In Lower Case
- Java Program to Print the English Alphabets In Lower Case
- Java Program to find Exponentiation
- Java Program to print alphabets in reverse
- Java Program to N th Multiplication table till M
- Java Program to sum N Postive numbers, Skip Negative Numbers.
- Java Program to find The Sum Of Multiple Positive Number,Stops If user Enters Negative Numbers