Java Program to print N Natural numbers in reverse
Get input n and print natural numbers from n in reverse.
Sample Input 1:
7
Sample Output 1:
The natural numbers in reverse: 7 6 5 4 3 2 1
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
import java.util.*;
class NaturalInRev
{
public static void main(String args[])
{
int lim,i;
System.out.println("Enter The Limit:");
Scanner sc=new Scanner(System.in);
lim=sc.nextInt();
System.out.println(" The Natural Numbers Is In Reverse Order:");
for(i=lim;i>=1;i--)
{
System.out.print(" "+i);
}
}
}
Program Explanation
1. Get input limit (from which number natural numbers to be printed in reverse)
2. Instruction(s) inside the for block{} are executed repeatedly till i greater than 0. (i>0)
for(i=lim;i>=1;i--)
3. Here i is initialized to limit and decremented by 1 for each iteration, instructions inside the for block are executed in every iteration. Iteration stops when i becomes lesser than or equal to 0.
so value of i will be printed like limit, limit-1,limit-2.....,3,2,1
Comments
Related Programs
- Java Program to print N Natural numbers
- Java Program to print N Whole numbers
- Java Program to calculate sum of First N Natural numbers
- Java Program to calculate sum of N given numbers
- Java Program to print sum of N ODD numbers
- Java Program to print Sum of N Even numbers
- Java Program to print ODD numbers till N
- Java Program to print Even numbers till N
- Java Program to calculate sum of Even numbers till N
- Java Program to calculate sum of ODD numbers till N
- Java Program to print Hello World for N times
- Java Program to print the first digit of a given number
- Java Program to find whether the first digit of given number is odd or even
- Java Program to multiply two numbers without using * operator
- Java Program to print Multiplication table of N
- Java Program to print English Alphabets between two Alphabets
- Java Program to Print the English Alphabets In Lower Case
- Java Program to Print the English Alphabets In Lower Case
- Java Program to find Exponentiation
- Java Program to print alphabets in reverse
- Java Program to N th Multiplication table till M
- Java Program to sum N Postive numbers, Skip Negative Numbers.
- Java Program to find The Sum Of Multiple Positive Number,Stops If user Enters Negative Numbers
coming Soon
coming Soon