Java Program to print Even numbers till N
Get input n and print n even numbers.
Sample Input 1:
7
Sample Output 1:
2 4 6 8 10 12 14
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
import java.util.*;
class NEven
{
public static void main(String args[])
{
int i,lim;
System.out.println("Enter The Value Of N");
Scanner sc=new Scanner(System.in);
lim=sc.nextInt();
System.out.println("The N Even Numbers: ");
for(i=2;i<=lim;i=i+2)
{
System.out.println(""+i);
}
}
}
Program Explanation
1. Get the input lim(Till which number the even numbers to be printed)
2. Instruction(s) inside the for block{} are executed repeatedly till the second expression (i<=lim) is true.
for(i=2;i<=lim;i=i+2)
3. Here i is initialized to 2 and i is incremented by 2 for each iteration, instructions inside the for block are executed in every iteration. Iteration stops when i becomes greater than lim.
so value of i (2,4,6,8,....) (even numbers till lim) in each iteration will be printed using system.out.println
Comments
Related Programs
- Java Program to print N Natural numbers
- Java Program to print N Whole numbers
- Java Program to print N Natural numbers in reverse
- Java Program to calculate sum of First N Natural numbers
- Java Program to calculate sum of N given numbers
- Java Program to print sum of N ODD numbers
- Java Program to print Sum of N Even numbers
- Java Program to print ODD numbers till N
- Java Program to calculate sum of Even numbers till N
- Java Program to calculate sum of ODD numbers till N
- Java Program to print Hello World for N times
- Java Program to print the first digit of a given number
- Java Program to find whether the first digit of given number is odd or even
- Java Program to multiply two numbers without using * operator
- Java Program to print Multiplication table of N
- Java Program to print English Alphabets between two Alphabets
- Java Program to Print the English Alphabets In Lower Case
- Java Program to Print the English Alphabets In Lower Case
- Java Program to find Exponentiation
- Java Program to print alphabets in reverse
- Java Program to N th Multiplication table till M
- Java Program to sum N Postive numbers, Skip Negative Numbers.
- Java Program to find The Sum Of Multiple Positive Number,Stops If user Enters Negative Numbers
coming Soon
coming Soon