Java Program to find whether the first digit of given number is odd or even
Get input num and check whether the first digit of number num is odd or even
Sample Input 1:
34
Sample Output 1:
The first digit is :Even
Sample Input 2:
67
Sample Output 2:
Even
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
Program or Solution
import java.util.*;
class Checker
{
public static void main(String args[])
{
int num;
Scanner sc=new Scanner(System.in);
System.out.println("Enter The Number:");
num=sc.nextInt();
while(num>=10)
{
num=num/10;
}
if(num%2==0)
{
System.out.println("The First Digit Is Even.");
}
else
{
System.out.println("The First Digit Is Odd.");
}
}
}
Program Explanation
1. Get num (to which first digit is to be identified)
2. Instruction(s) inside the while block{} are executed repeatedly till expression (num>=10) is true.
3. Divide the number num by 10 untill it becomes lesser than 10.
once it is less than 10, check whether the number is even
if even, print even. else print odd.
statement num = num/10 divides the num by 10 repeatedly until it num is less than 10
Example
487
487/10 = 48
48 / 10 = 4
4 is less than 10, so check whether 4 is even.
4 is even, so print even.
Comments
Related Programs
- Java Program to print N Natural numbers
- Java Program to print N Whole numbers
- Java Program to print N Natural numbers in reverse
- Java Program to calculate sum of First N Natural numbers
- Java Program to calculate sum of N given numbers
- Java Program to print sum of N ODD numbers
- Java Program to print Sum of N Even numbers
- Java Program to print ODD numbers till N
- Java Program to print Even numbers till N
- Java Program to calculate sum of Even numbers till N
- Java Program to calculate sum of ODD numbers till N
- Java Program to print Hello World for N times
- Java Program to print the first digit of a given number
- Java Program to multiply two numbers without using * operator
- Java Program to print Multiplication table of N
- Java Program to print English Alphabets between two Alphabets
- Java Program to Print the English Alphabets In Lower Case
- Java Program to Print the English Alphabets In Lower Case
- Java Program to find Exponentiation
- Java Program to print alphabets in reverse
- Java Program to N th Multiplication table till M
- Java Program to sum N Postive numbers, Skip Negative Numbers.
- Java Program to find The Sum Of Multiple Positive Number,Stops If user Enters Negative Numbers