Java Program to find The Sum Of Multiple Positive Number,Stops If user Enters Negative Numbers
Get positive integers from user till user enters a negative integer. calculate sum of positive integers.
Sample Input 1:
5 6 7 2 1 8 -9
Sample Output 1:
29
Sample Input 2:
3 23 -76
Sample Output 2:
26
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
//To Find The Sum Of Multiple Positive Number,Stops If user Enters Negative Numbers...
import java.util.*;
class Program
{
public static void main(String args[])
{
int size,sum=0,i;
Scanner sc=new Scanner(System.in);
System.out.println("Enter The Size Of Array:");
size=sc.nextInt();
int a[]=new int[size];
System.out.println("Enter The Array Elements:");
for(i=0;i<size;i++)
{
a[i]=sc.nextInt();
}
for(i=0;i<size;i++)
{
if(a[i]>0)
{
sum=sum+a[i];
}
else
{
break;
}
}
System.out.println("The Sum Is:"+sum);
}
}
Program Explanation
Comments
Related Programs
- Java Program to print N Natural numbers
- Java Program to print N Whole numbers
- Java Program to print N Natural numbers in reverse
- Java Program to calculate sum of First N Natural numbers
- Java Program to calculate sum of N given numbers
- Java Program to print sum of N ODD numbers
- Java Program to print Sum of N Even numbers
- Java Program to print ODD numbers till N
- Java Program to print Even numbers till N
- Java Program to calculate sum of Even numbers till N
- Java Program to calculate sum of ODD numbers till N
- Java Program to print Hello World for N times
- Java Program to print the first digit of a given number
- Java Program to find whether the first digit of given number is odd or even
- Java Program to multiply two numbers without using * operator
- Java Program to print Multiplication table of N
- Java Program to print English Alphabets between two Alphabets
- Java Program to Print the English Alphabets In Lower Case
- Java Program to Print the English Alphabets In Lower Case
- Java Program to find Exponentiation
- Java Program to print alphabets in reverse
- Java Program to N th Multiplication table till M
- Java Program to sum N Postive numbers, Skip Negative Numbers.
coming Soon
coming Soon