Java Program to find Exponentiation
Get two inputs num1 and num2, compute the exponentiation of base num1 and power num2 without using predefined functions
Sample Input 1:
2 4
Sample Output 1:
16
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
//To Find N power of M (Exponentiation)...
import java.util.*;
class Program
{
public static void main(String args[])
{
int base,pow,product=1;
Scanner sc=new Scanner(System.in);
System.out.println("Enter The Base:");
base=sc.nextInt();
System.out.println("Enter The Power:");
pow=sc.nextInt();
while(pow>0)
{
product=product*base;
pow--;
}
System.out.println("The Output Is:"+product);
}
}
Program Explanation
Comments
Related Programs
- Java Program to print N Natural numbers
- Java Program to print N Whole numbers
- Java Program to print N Natural numbers in reverse
- Java Program to calculate sum of First N Natural numbers
- Java Program to calculate sum of N given numbers
- Java Program to print sum of N ODD numbers
- Java Program to print Sum of N Even numbers
- Java Program to print ODD numbers till N
- Java Program to print Even numbers till N
- Java Program to calculate sum of Even numbers till N
- Java Program to calculate sum of ODD numbers till N
- Java Program to print Hello World for N times
- Java Program to print the first digit of a given number
- Java Program to find whether the first digit of given number is odd or even
- Java Program to multiply two numbers without using * operator
- Java Program to print Multiplication table of N
- Java Program to print English Alphabets between two Alphabets
- Java Program to Print the English Alphabets In Lower Case
- Java Program to Print the English Alphabets In Lower Case
- Java Program to print alphabets in reverse
- Java Program to N th Multiplication table till M
- Java Program to sum N Postive numbers, Skip Negative Numbers.
- Java Program to find The Sum Of Multiple Positive Number,Stops If user Enters Negative Numbers
coming Soon
coming Soon