Java Program to calculate sum of Even numbers till N
Get input n and calculate the sum of even numbers till n
Sample Input 1:
5
Sample Output 1:
The Sum of Even Number till N:6(2+4)
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
Program or Solution
import java.util.*;
class SumOfNEven
{
public static void main(String args[])
{
int i,j,N,sum=0;
System.out.println("Enter The Value Of N");
Scanner sc=new Scanner(System.in);
N=sc.nextInt();
for(i=2;i<N;i+=2)
sum+=i;
System.out.println("The Sum Of N Even Numbers: "+sum);
}
}
Program Explanation
1. Get input N (To which even numbers to be added)
2. Instruction(s) inside the for block{} are executed repeatedly till the second expression (j<=N) is true.
for(i=2;i<N;i+=2)
3. Here i is initialized to 2 and incremented by 2 for each iteration, instructions inside the for block are executed in every iteration. iteration stops when i becomes greater than n.
so value of i (2,4,6,...n)will be added to sum.
sum = sum + i
sum = 0 + 2
sum = 2 + 4
sum = 6 + 6
...................
after adding all even numbers till N to sum, sum will be printed using system.out.println.
Comments
Related Programs
- Java Program to print N Natural numbers
- Java Program to print N Whole numbers
- Java Program to print N Natural numbers in reverse
- Java Program to calculate sum of First N Natural numbers
- Java Program to calculate sum of N given numbers
- Java Program to print sum of N ODD numbers
- Java Program to print Sum of N Even numbers
- Java Program to print ODD numbers till N
- Java Program to print Even numbers till N
- Java Program to calculate sum of ODD numbers till N
- Java Program to print Hello World for N times
- Java Program to print the first digit of a given number
- Java Program to find whether the first digit of given number is odd or even
- Java Program to multiply two numbers without using * operator
- Java Program to print Multiplication table of N
- Java Program to print English Alphabets between two Alphabets
- Java Program to Print the English Alphabets In Lower Case
- Java Program to Print the English Alphabets In Lower Case
- Java Program to find Exponentiation
- Java Program to print alphabets in reverse
- Java Program to N th Multiplication table till M
- Java Program to sum N Postive numbers, Skip Negative Numbers.
- Java Program to find The Sum Of Multiple Positive Number,Stops If user Enters Negative Numbers