C Program to Arithmetic Calculator using switch case Statements
Get a binary arithmetic expression and solve the expression.
Sample Input 1:
12+9
Sample Output 1:
21
Sample Input 2:
4*5
Sample Output 2:
20
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
int main()
{
int num1,num2,output;
char operator;
printf("Enter a binary expression:");
scanf("%d %c %d",&num1,&operator,&num2);
switch(operator)
{
case '+':
output=num1+num2;
break;
case '-':
output=num1-num2;
break;
case '*':
output=num1*num2;
break;
case '/':
output=num1/num2;
break;
case '%':
output=num1%num2;
break;
default :
printf("invalid operation");
break;
}
printf("%d",output);
return 0;
}
Program Explanation
Based on the second character operator, instructions in any one of the case will be executed.Comments
Related Programs
- C Program to calculate discount for purchase above 5000
- C Program to find greatest among two numbers
- C Program to find smallest among two numbers
- C Program to find whether the given number is odd or even number
- C Program to find whether the difference between two numbers is even or odd
- C Program to find whether the given number is 3 digit number or not
- C Program to find greatest among three numbers
- C Program to find smallest among three numbers
- C Program to find whether the given number is divisible by 3
- C Program to find whether the given year is leap year or not
- C Program to find whether the last digit of given number is divisible by 3
- C Program to grade calculation system
- C Program to find the whether the last digit of given two numbers are equal or not
- C Program to calculate different discount for different Bill amount
- C Program to check whether ith bit in a number N is set or not
- C Program to check odd or even using bitwise operator
coming Soon
coming Soon