C Program to calculate discount for purchase above 5000
Get price and quantity of a product, calculate bill amount and calculate 10% discount for the bill amount 5000 and above.
Sample Input 1:
10 400
Sample Output 1:
4000
Sample Input 2:
10 500
Sample Output 2:
4500
Flow Chart Design
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include <stdio.h>
int main(void)
{
double quantity,price,amount,discount;
printf("Enter Quantity and Price:");
scanf("%lf %lf",&quantity, &price);
amount=quantity*price;
if(amount>5000)
{
discount=amount*0.05;
amount=amount-discount;
}
printf("%lf",amount);
return 0;
}
Program Explanation
Get two inputs quantity and price from user using scanf statement
Calculate amount by using the expression amount = quantity * price
Check whether amount is greater than 5000 using if statement.
if amount is greater than 5000 then calculate discount and amount using the expressions discount = amount * 0.05 and amount = amount - discount.
print amount using printf statement.
Comments
Related Programs
- C Program to find greatest among two numbers
- C Program to find smallest among two numbers
- C Program to find whether the given number is odd or even number
- C Program to find whether the difference between two numbers is even or odd
- C Program to find whether the given number is 3 digit number or not
- C Program to find greatest among three numbers
- C Program to find smallest among three numbers
- C Program to find whether the given number is divisible by 3
- C Program to find whether the given year is leap year or not
- C Program to find whether the last digit of given number is divisible by 3
- C Program to Arithmetic Calculator using switch case Statements
- C Program to grade calculation system
- C Program to find the whether the last digit of given two numbers are equal or not
- C Program to calculate different discount for different Bill amount
- C Program to check whether ith bit in a number N is set or not
- C Program to check odd or even using bitwise operator
coming Soon
coming Soon