C Program to find smallest among two numbers
Get two numbers num1 and num2 and find the smallest one among num1 and num2.
Sample Input 1:
5 6
Sample Output 1:
5
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include <stdio.h>
int main(void)
{
int num1,num2;
printf("Enter two numbers:");
scanf("%d %d",&num1,&num2);
if(num1<num2)
{
printf("%d is smaller",num1);
}
else if(num2<num1)
{
printf("%d is smaller",num2);
}
else
{
printf("%d and %d are equal",num1,num2);
}
return 0;
}
Program Explanation
Get two inputs num1 and num2 from user using scanf statement
check whether num1 is smaller than num2 using if statement.
if num1 is smaller print num1 using printf statment, else check whether num2 is smaller than num1 using elseif statement.
If num2 is smaller print num2 using printf statement, else print num1 and num2 are equal using printf statment.
Comments
Related Programs
- C Program to calculate discount for purchase above 5000
- C Program to find greatest among two numbers
- C Program to find whether the given number is odd or even number
- C Program to find whether the difference between two numbers is even or odd
- C Program to find whether the given number is 3 digit number or not
- C Program to find greatest among three numbers
- C Program to find smallest among three numbers
- C Program to find whether the given number is divisible by 3
- C Program to find whether the given year is leap year or not
- C Program to find whether the last digit of given number is divisible by 3
- C Program to Arithmetic Calculator using switch case Statements
- C Program to grade calculation system
- C Program to find the whether the last digit of given two numbers are equal or not
- C Program to calculate different discount for different Bill amount
- C Program to check whether ith bit in a number N is set or not
- C Program to check odd or even using bitwise operator
coming Soon
coming Soon