C Program to find the whether the last digit of given two numbers are equal or not
Get two numbers num1 and num2 and check whether last digit of num1 and num2 are equal or not?.
Sample Input 1:
65 45
Sample Output 1:
Equal
Sample Input 2:
35 38
sample Output 2:
Not Equal
Flow Chart Design
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
int main()
{
int num1,num2;
printf("Enter two numbers:");
scanf("%d %d"&num1,&num2);
if(num1%10==num2%10)
{
printf("%d and %d are equal",num1%10,num2%10);
}
else
{
printf("%d and %d are not equal",num1%10,num2%10);
}
return 0;
}
Program Explanation
extract the last digits of num1 and num2 using %10, then compare last digits.Comments
Related Programs
- C Program to calculate discount for purchase above 5000
- C Program to find greatest among two numbers
- C Program to find smallest among two numbers
- C Program to find whether the given number is odd or even number
- C Program to find whether the difference between two numbers is even or odd
- C Program to find whether the given number is 3 digit number or not
- C Program to find greatest among three numbers
- C Program to find smallest among three numbers
- C Program to find whether the given number is divisible by 3
- C Program to find whether the given year is leap year or not
- C Program to find whether the last digit of given number is divisible by 3
- C Program to Arithmetic Calculator using switch case Statements
- C Program to grade calculation system
- C Program to calculate different discount for different Bill amount
- C Program to check whether ith bit in a number N is set or not
- C Program to check odd or even using bitwise operator
coming Soon
coming Soon