C Program to find whether the difference between two numbers is even or odd
Get two numbers num1 and num2 and check whether the difference between num1 and num2 is odd or even?
Sample Input 1:
45 56
Sample Output 1:
ODD
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
int main()
{
int num1,num2,difference;
printf("Enter two numbers:");
scanf("%d %d"&num1,&num2);
difference=num1-num2;
if(difference%2==0)
{
printf("The difference %d is even",difference);
}
else
{
printf("The difference %d is odd",difference);
}
return 0;
}
Program Explanation
Get two inputs num1 and num2 from user using scanf statement
Calculate difference between num1 and num2 using the expression difference = num1 - num2.
check whether the remainder of difference divided by 2 is equal to 0 using if statement.
if it is 0, then print difference is even using printf statement.
Else print difference is odd using printf statement.
Comments
Related Programs
- C Program to calculate discount for purchase above 5000
- C Program to find greatest among two numbers
- C Program to find smallest among two numbers
- C Program to find whether the given number is odd or even number
- C Program to find whether the given number is 3 digit number or not
- C Program to find greatest among three numbers
- C Program to find smallest among three numbers
- C Program to find whether the given number is divisible by 3
- C Program to find whether the given year is leap year or not
- C Program to find whether the last digit of given number is divisible by 3
- C Program to Arithmetic Calculator using switch case Statements
- C Program to grade calculation system
- C Program to find the whether the last digit of given two numbers are equal or not
- C Program to calculate different discount for different Bill amount
- C Program to check whether ith bit in a number N is set or not
- C Program to check odd or even using bitwise operator
coming Soon
coming Soon