C Program to find whether the given number is 3 digit number or not
Get a number num and check whether num is three digit number or not?.
Sample Input 1:
1000
Sample Output 1:
Not a three digit number
Sample Input 2:
987
Sample Output 2:
Three digit number
Flow Chart Design
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
int main()
{
int num;
printf("Enter a number:");
scanf("%d"&num);
if(num>99 && num<1000)
{
printf("%d is a 3 digit number",num);
}
else
{
printf("%d is not a 3 digit number",num);
}
return 0;
}
Program Explanation
Get input num from user using scanf statement
check whether the num is greater than 99 and less than 100 using if statement.
if it is true, then print num is three digit number using printf statement.
Else print num is not three digit number using printf statement.
Comments
Related Programs
- C Program to calculate discount for purchase above 5000
- C Program to find greatest among two numbers
- C Program to find smallest among two numbers
- C Program to find whether the given number is odd or even number
- C Program to find whether the difference between two numbers is even or odd
- C Program to find greatest among three numbers
- C Program to find smallest among three numbers
- C Program to find whether the given number is divisible by 3
- C Program to find whether the given year is leap year or not
- C Program to find whether the last digit of given number is divisible by 3
- C Program to Arithmetic Calculator using switch case Statements
- C Program to grade calculation system
- C Program to find the whether the last digit of given two numbers are equal or not
- C Program to calculate different discount for different Bill amount
- C Program to check whether ith bit in a number N is set or not
- C Program to check odd or even using bitwise operator
coming Soon
coming Soon