C Program to find greatest among three numbers
Get three numbers num1, num2 and num3 and find the greatest one among num1,num2 and num3.
Sample Input 1:
5 6 2
Sample Output 1:
6
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
int main()
{
int num1,num2,num3;
printf("Enter three numbers:");
scanf("%d %d %d"&num1,&num2,&num3);
if(num1 > num2 && num1 > num3)
{
printf("%d is greatest",num1);
}
else if(num2 > num3)
{
printf("%d is greatest",num2);
}
else
{
printf("%d is greatest",num3);
}
return 0;
}
Program Explanation
Get three inputs num1, num2 and num3 from user using scanf statements.
Check whether num1 is greater than num2 and num3 using if statement, if it is true print num1 is greatest using printf statement.
Else, num2 or num3 is greatest.
So check whether num2 is greater than num3 using elseif statement.
if num2 is greater, then print num2 is greater using printf statement.
Else, print num3 is greater using printf statement.
Comments
Related Programs
- C Program to calculate discount for purchase above 5000
- C Program to find greatest among two numbers
- C Program to find smallest among two numbers
- C Program to find whether the given number is odd or even number
- C Program to find whether the difference between two numbers is even or odd
- C Program to find whether the given number is 3 digit number or not
- C Program to find smallest among three numbers
- C Program to find whether the given number is divisible by 3
- C Program to find whether the given year is leap year or not
- C Program to find whether the last digit of given number is divisible by 3
- C Program to Arithmetic Calculator using switch case Statements
- C Program to grade calculation system
- C Program to find the whether the last digit of given two numbers are equal or not
- C Program to calculate different discount for different Bill amount
- C Program to check whether ith bit in a number N is set or not
- C Program to check odd or even using bitwise operator
coming Soon
coming Soon