C Program to find whether the last digit of given number is divisible by 3
Get a number num and check whether last digit of num is divisible by three.
Sample Input 1:
27
Sample Output 1:
last digit not Divisible by 3
Sample Input 2:
43
Sample Output 2:
last digit divisible by 3
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
int main()
{
int num,digit;
printf("Enter a number:");
scanf("%d"&num);
digit=num%10;
if(digit%3==0)
{
printf("%d is divisible by 3",digit);
}
else
{
printf("%d is not divisible by 3",digit);
}
return 0;
}
Program Explanation
Get input num from user using scanf statement extract last digit from num using the expression digit=num%10.
check whether the remainder of digit divided by 3 is equal to 0 using if statement.
if it is 0, then print tdig is divisible by 3 using printf statement.
Else print digit is not divisible by 3 using printf statement.
Note: any number modulus of 10 gives last digit of number.
Comments
Related Programs
- C Program to calculate discount for purchase above 5000
- C Program to find greatest among two numbers
- C Program to find smallest among two numbers
- C Program to find whether the given number is odd or even number
- C Program to find whether the difference between two numbers is even or odd
- C Program to find whether the given number is 3 digit number or not
- C Program to find greatest among three numbers
- C Program to find smallest among three numbers
- C Program to find whether the given number is divisible by 3
- C Program to find whether the given year is leap year or not
- C Program to Arithmetic Calculator using switch case Statements
- C Program to grade calculation system
- C Program to find the whether the last digit of given two numbers are equal or not
- C Program to calculate different discount for different Bill amount
- C Program to check whether ith bit in a number N is set or not
- C Program to check odd or even using bitwise operator
coming Soon
coming Soon